ABE "?"

Bug reports and enhancement requests

ABE "?"

Postby Alan Baxter » Tue May 26, 2009 6:37 am

@Giorgio:
Clicking on the "?" in the upper-right corner of the ABE options opens up http://noscript.net/. That doesn't seem to be very informative. Did you intend it to do something else yet?
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10
Alan Baxter
Ambassador
 
Posts: 1586
Joined: Fri Mar 20, 2009 4:47 am
Location: Colorado, USA

Re: ABE "?"

Postby Giorgio Maone » Tue May 26, 2009 8:36 am

Yes, it points at http://noscript.net/help/ABE (which is meant to be part a more general help system), but at this moment the page is still missing and noscript.net redirects every 404 not found to the root path.
Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10 (.NET CLR 3.5.30729)
User avatar
Giorgio Maone
Site Admin
 
Posts: 7322
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy

Re: ABE "?"

Postby GµårÐïåñ » Tue May 26, 2009 9:36 pm

I figured as much but good to know, thanks.
~.:[ Lï£ê ï§ å Lêmðñ åñÐ Ì Wåñ† M¥ Mðñê¥ ßå¢k ]:.~
[ Major's Blog ] .:. [ Security Pack ] .:. [ Productivity ]
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10
User avatar
GµårÐïåñ
Lieutenant Colonel
 
Posts: 2918
Joined: Fri Mar 20, 2009 5:19 am
Location: PST - USA

Re: ABE "?"

Postby tlu » Fri Jun 05, 2009 8:30 pm

Giorgio Maone wrote:Yes, it points at http://noscript.net/help/ABE (which is meant to be part a more general help system), but at this moment the page is still missing and noscript.net redirects every 404 not found to the root path.


Thanks, Giorgio, that page now exists but I'm a little bit confused. It says: "A preliminary ABE implementation is provided with NoScript 1.9.3.6 and above, and local rulesets can be configured from NoScript Options|Advanced|ABE." There is indeed an ABE folder in my profile but its rules subfolder is empty. And consequently, Noscript itself doesn't display any ruleset and I'm not able to edit/change anything. Have I missed anything?

Another funny thing: I wasn't able to open that rules subfolder. I checked the rights (I'm on Ubuntu 9.04) and noticed that I had read and write permission but no permission to open the folder (rw-). I've changed that, of course, but my question is: Is that intentional?
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2a1pre) Gecko/20090603 Ubuntu/9.04 (jaunty) Minefield/3.6a1pre
tlu
Senior Member
 
Posts: 129
Joined: Fri Jun 05, 2009 8:01 pm

Re: ABE "?"

Postby Giorgio Maone » Fri Jun 05, 2009 8:58 pm

It was a bug with the default file creation permissions on Ubuntu, fixed in 1.9.3.7 latest development build.
Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10 (.NET CLR 3.5.30729)
User avatar
Giorgio Maone
Site Admin
 
Posts: 7322
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy

Re: ABE "?"

Postby tlu » Fri Jun 05, 2009 9:18 pm

Giorgio Maone wrote:It was a bug with the default file creation permissions on Ubuntu, fixed in 1.9.3.7 latest development build.


I'm already using that version but the problem persists.
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2a1pre) Gecko/20090603 Ubuntu/9.04 (jaunty) Minefield/3.6a1pre
tlu
Senior Member
 
Posts: 129
Joined: Fri Jun 05, 2009 8:01 pm

Re: ABE "?"

Postby Giorgio Maone » Fri Jun 05, 2009 9:26 pm

To recreate the defaults you can either use the "Reset" button (which will reset the other preferences as well, though) or enter the following in the Error Console:
Code: Select all
top.opener.noscriptOverlay.ns.__parent__.ABE.resetDefaults()
Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10 (.NET CLR 3.5.30729)
User avatar
Giorgio Maone
Site Admin
 
Posts: 7322
Joined: Wed Mar 18, 2009 11:22 pm
Location: Palermo - Italy

Re: ABE "?"

Postby tlu » Fri Jun 05, 2009 9:40 pm

Ahhh - great! That solved the problem - everything works now as expected :D
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2a1pre) Gecko/20090603 Ubuntu/9.04 (jaunty) Minefield/3.6a1pre
tlu
Senior Member
 
Posts: 129
Joined: Fri Jun 05, 2009 8:01 pm

Re: ABE "?"

Postby Alan Baxter » Sat Jun 06, 2009 2:57 pm

Resolved and locked at OP's request. Please start a new topic for any new ABE questions or comments.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10
Alan Baxter
Ambassador
 
Posts: 1586
Joined: Fri Mar 20, 2009 4:47 am
Location: Colorado, USA


Return to NoScript Development

Who is online

Users browsing this forum: No registered users and 1 guest